[Development] How can Qt 5.6.0 MinGW pass in CI with QTBUG-49971 open?

Roland Winklmeier roland.m.winklmeier at gmail.com
Thu Mar 3 17:37:12 CET 2016


2016-03-03 16:51 GMT+01:00 Thiago Macieira <thiago.macieira at intel.com>:

> On quinta-feira, 3 de março de 2016 10:51:40 PST Roland Winklmeier wrote:
> > No matter if I download the source from download.qt.io or clone from git
> > and run the normal build as configured in CI, I get the build error. I'm
> > not changing any flags. So my and CI configuration should be exactly the
> > same and either both pass or fail. But CI passes and the build of several
> > people locally fail. I wonder how thats possible.
>
> Can you give us the command-line of the compilation that failed? Like I
> said,
> -Werror=undef is not supposed to be enabled by default, unless you turn
> headersclean on. And that's not the default.
>
> Note that -developer-build turns it on. But if you use that option, you
> say "I
> will fix bugs I find too".
>

I think that is the "mistake" I did. I'm pretty sure I tried the
-developer-build.

There is now a fix on the way and it was always easy to workaround the
problem when building locally. I also understand why CI passed (no
developer-build turned on) and everything makes sense now. I'm going to try
once more with latest RC sources and then it should be good.

Thanks everyone.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/development/attachments/20160303/6a4ef9d8/attachment.html>


More information about the Development mailing list