[Development] Compiling QT 5.7 Windows 64-bit

Partha Bagchi partha1b at gmail.com
Tue Mar 29 01:20:56 CEST 2016

On Mon, Mar 28, 2016 at 6:49 PM, Partha Bagchi <partha1b at gmail.com> wrote:

> On Mon, Mar 28, 2016 at 4:44 PM, Thiago Macieira <
> thiago.macieira at intel.com> wrote:
>> On segunda-feira, 28 de março de 2016 17:13:56 PDT Rafael Roquetto wrote:
>> > Hey,
>> >
>> > 1. don't use msys shell.
>> > 2. make sure stuff like sh.exe is not on your path
>> Doesn't match my recommendation. I do use the msys shell and I do have
>> sh.exe
>> on PATH.
>> Correct. However, msys shell does not work and you can't run configure
> without getting errors.
>> > 3. use configure.bat (not the configure shell script)
>> However, I do use configure.bat. To run it from the msys shell, I need to
>> run:
>>         cmd \ /c configure.bat [args]
>> As I mentioned at the top of the thread. I switched to Windows cmdline to
> run configure.bat. After that I ran mingw32-make where I got into the
> trouble mentioned at the top of the thread.
> Based on your suggestion above, I am now running it all within a msys
> shell with cmd (which btw opens a subshell for me) and I am running
> configure with args.
> Then I exited from the subshell and am running make. Will keep you posted.

Same difference. I am now configured. However, when I run make, I get the
following error (after a long time):

g++ -c -pipe -fno-keep-inline-dllexport -O2 -std=c++1z -fno-exceptions
-frtti -Wall -Wextra -Wvla -Wdate-time -DUNICODE
-DWTFInvokeCrashHook=qmlWTFInvokeCrashHook -DNOMINMAX -DENABLE_LLINT=0
-DQT_NETWORK_LIB -DQT_CORE_LIB -I. -IZ:/opts/opt64-kde/include
-IZ:/opts/opt64-kde/include/freetype2 -IZ:/opts/opt64-kde/include/glib-2.0
-Imemory -I. -Icompiler -I. -I../3rdparty/masm/jit
-I../3rdparty/masm/assembler -I../3rdparty/masm/runtime
-I../3rdparty/masm/wtf -I../3rdparty/masm/stubs
-I../3rdparty/masm/stubs/wtf -I../3rdparty/masm
-I../3rdparty/masm/disassembler -I../3rdparty/masm/disassembler/udis86
-Ijit -I. -I.generated/release -Ijsruntime -I. -Idebugger -Ianimations
-I../../include -I../../include/QtQml -I../../include/QtQml/5.7.0
-I../../include/QtQml/5.7.0/QtQml -Itmp
-IZ:/src/qt5/qtbase/include/QtCore/5.7.0/QtCore -IZ:/src/qt5/qtbase/include
-IZ:/src/qt5/qtbase/include/QtNetwork -IZ:/src/qt5/qtbase/include/QtCore
-I.moc/release -IZ:/src/qt5/qtbase/mkspecs/win32-g++  -o
.obj/release/qv4regalloc.o jit/qv4regalloc.cpp
jit/qv4regalloc.cpp:648:8: error: missing binary operator before token "("
 #if CPU(X86) || CPU(X86_64)
Makefile.Release:16312: recipe for target `.obj/release/qv4regalloc.o'
make[4]: *** [.obj/release/qv4regalloc.o] Error 1
make[4]: Leaving directory `/usr/src/qt5/qtdeclarative/src/qml'
Makefile:34: recipe for target `release' failed
make[3]: *** [release] Error 2
make[3]: Leaving directory `/usr/src/qt5/qtdeclarative/src/qml'
Makefile:46: recipe for target `sub-qml-make_first-ordered' failed
make[2]: *** [sub-qml-make_first-ordered] Error 2
make[2]: Leaving directory `/usr/src/qt5/qtdeclarative/src'
Makefile:41: recipe for target `sub-src-make_first' failed
make[1]: *** [sub-src-make_first] Error 2
make[1]: Leaving directory `/usr/src/qt5/qtdeclarative'
Makefile:326: recipe for target `module-qtdeclarative-make_first' failed
make: *** [module-qtdeclarative-make_first] Error 2

> --
>> Thiago Macieira - thiago.macieira (AT) intel.com
>>   Software Architect - Intel Open Source Technology Center
>> _______________________________________________
>> Development mailing list
>> Development at qt-project.org
>> http://lists.qt-project.org/mailman/listinfo/development
> Thanks for staying on this with me!! I totally appreciate it.
> Partha
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/development/attachments/20160328/c7e787e5/attachment.html>

More information about the Development mailing list