[Development] Qt/XCB applications and deadkeys (which cease working)

René J.V. Bertin rjvbertin at gmail.com
Thu Jun 8 16:04:19 CEST 2017

On Thursday June 08 2017 15:43:07 Allan Sandfeld Jensen wrote:

> I just ran into the same thing today not an hour ago. No idea what triggered 
> it, but I haven't seen it before. I solved it by starting ibus, but I guess 
> that just adds another layer of interpretting keys. Also newly started qt5 
> applications had working dead-keys too, it was just all running qt5 
> applications that broke.

Wow, at least now I know "it's not just me" ... What DE are you using?

I installed ibus a while back to have another mechanism for swapping and restoring keyboard layouts. Hasn't helped me at all until now (and it's been running ever since I installed it).

Next time I'll see if newly started Qt applications are still affected. I think I must already have tried restarting the application I get this most often in (KDE4/Qt4 based KMail) without much success. Maybe you ran into the version that can be cured by cycling keyboard layouts.


More information about the Development mailing list