[Development] Problems building qtwebkit in 5.9.1

Harald Vistnes harald.vistnes at gmail.com
Wed Jun 14 11:49:00 CEST 2017


Has there been a change in the dependencies for qtwebkit in 5.9.1? I am not
able to build it anymore.

I am using these commands:

perl init-repository

configure -prefix %CD%\qtbase -opensource -shared -confirm-license
-debug-and-release -release -opengl desktop -qt-zlib -qt-libpng -no-angle
-qt-libjpeg -icu -skip qtconnectivity -skip qtlocation -skip qtsensors
-skip qtwayland -skip qtserialbus -skip qtserialport -skip
qtvirtualkeyboard -skip qtdatavis3d -skip qtcharts -skip qtpurchasing -skip
qtcanvas3d -skip qtspeech -skip qtandroidextras -skip qtnetworkauth -skip
qtquickcontrols -skip qtwebengine -platform win32-msvc2015 -nomake tests

cd qtwebkit

../qtbase/bin/qmake.exe WebKit.pro

In 5.9.1 I get the following output from qmake:

Running configure tests...

Checking for fontconfig... no
Checking for gccdepends... no
Checking for glx... no
Checking for gnuld... no
Checking for icu... yes
Checking for leveldb... no
Checking for libsqlite3... no
Checking for libwebp... no
Checking for libXcomposite... no
Checking for libxml2... no
Checking for libXrender... no
Checking for libxslt... no
Checking for libzlib... no
Project ERROR: Could not find feature system-jpeg.

I did not get this error in 5.9.0 or in any previous versions.

I am on Windows, but a colleague got the same error on Linux. He also tried
to configure with -system-jpeg, but with the same result.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/development/attachments/20170614/a344c674/attachment.html>

More information about the Development mailing list