[Development] QList

Kevin Kofler kevin.kofler at chello.at
Sun Mar 19 00:59:46 CET 2017


Marc Mutz wrote:
> One reason I'm against keeping "QList" as a fully supported Qt container
> name is the unfortunate impedance mismatch (all Qt's fault) with
> std::list. I don't want Qt to continue to poison people's minds with that
> mixup.

Both the STL and Qt are equally at fault for using a terse, incompletely 
specified name there. The STL type should be called linked_list (just like 
the Qt and Java equivalents). The Qt QList could probably have received a 
better name too, especially considering the STL list was there first (though 
there is at least a logic behind calling the "default" list type just 
"list").

It is unfortunate that the STL consistently uses terse misleading names 
(e.g. "empty"), and even abbreviations such as "deque".

> Our containers _still_ don't support move semantics correctly.

Move semantics are almost useless in a world of implicitly shared 
containers. You save the reference counting and that's all.

        Kevin Kofler




More information about the Development mailing list