[Development] QtWebKit is coming back (part 2)

Konstantin Tokarev annulen at yandex.ru
Wed May 3 19:55:49 CEST 2017

03.05.2017, 20:44, "Thiago Macieira" <thiago.macieira at intel.com>:
> Em quarta-feira, 3 de maio de 2017, às 08:03:50 PDT, Konstantin Tokarev
> escreveu:
>>  I'm not sure it would be acceptable, because updated QtWebKit requires full
>>  C++11 support in the compiler (gcc >= 4.9, 4.8 possible with disabling some
>>  features, or with code changes, which were not done yet).
>>  Also, there are differences in supported platforms and system requirements.
>>  macOS: One user reported that QtWebKit TP5 built for OS X 10.9 target is
>>  working fine on OS X 10.7, however the oldest officially supported version
>>  is 10.10 (as in upstream). I'm pretty sure that WK2 IPC with Mach ports
>>  will break when compiling for older targets, though it should be possible
>>  to switch to unix sockets just for 5.6.
>>  Windows: Windows XP support seems to be feasible, if needed, without new
>>  MediaFoundation-based player. Will require backporting Conan-related patches
>>  in qt5.git to 5.6 branch.
>>  Linux: GStreamer 0.10 is not supported, so official builds with video will
>>  have to use QtMultimedia MediaPlayer implementation.
>>  I'm not sure about QNX support in QtWebKit 5.6, it is skipped in CI now
>>  because of missing ICU. However, I guess it will be possible to reintroduce
>>  QNX support if there are interested folks here, at least Widgets API.
> None of those look like deal-breakers. You should be able to:
>  * require C++11 [*] and require newer compilers than 5.6 does
>  * drop support for older platforms (XP, macOS < 10.9, etc.)
>  * require upgraded libraries, like GStreamer
> Especially if you're going to do releases out of phase with Qt, it should be
> fine to require more than 5.6 did. And people should just accept it: if you're
> dealing with something that evolves rapidly and is a security-sensitive, you
> should be prepared to upgrade your environment quickly too.
> [*] actually, we should remove the option from configure.

So, do you think we should update 5.6 branch of QtWebKit with wip/next contents,
fix qmake wrapper project to work with Qt 5.6, and raise requirements to whatever it
can require with Qt 5.9? That's fine with me.

> --
> Thiago Macieira - thiago.macieira (AT) intel.com
>   Software Architect - Intel Open Source Technology Center
> _______________________________________________
> Development mailing list
> Development at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/development


More information about the Development mailing list