[Development] Deprecation/removal model going into Qt 6

Lisandro Damián Nicanor Pérez Meyer perezmeyer at gmail.com
Sun Jun 2 19:33:21 CEST 2019


On Sun, 2 Jun 2019 at 13:59, Lisandro Damián Nicanor Pérez Meyer
<perezmeyer at gmail.com> wrote:
>
> On Sun, 2 Jun 2019 at 10:10, Allan Sandfeld Jensen <kde at carewolf.com> wrote:
> [snip]
> > >
> > I have no problem with breaking ABI more often but allowing it in every minor
> > releases probably goes to far. Perhaps every second LTS (every 3 years), might
> > be better.
>
> That would work as long as related applications (moc, linguist stuff,
> etc) remain either **fully** backwards compatible within the major
> version *or* they are also marked with the minor. For example instead
> of shipping moc6 one could ship moc6.<API/ABI stable LTS>, like let's
> say moc60, moc66 or alike.

s/would/might/. It will still mean that distros will need to ship
every LTS for at least ~4 years, or force lot of applications to get
removed from their archives. We still have Qt4 around...


More information about the Development mailing list