[Development] Assistant WebKit/WebEngine support

Konstantin Tokarev annulen at yandex.ru
Tue May 21 14:50:36 CEST 2019



21.05.2019, 15:47, "Bastiaan Veelo" <bastiaan at veelo.net>:
> On 20/05/2019 19:02, Konstantin Tokarev wrote:
>>  20.05.2019, 19:58, "Bastiaan Veelo" <bastiaan at veelo.net>:
>>>  On 20/05/2019 17:56, Konstantin Tokarev wrote:
>>>>    20.05.2019, 18:27, "Bastiaan Veelo" <bastiaan at veelo.net>:
>>>>>    On 20/05/2019 16:51, Konstantin Tokarev wrote:
>>>>>>      Note that it should be possible to rebuild QtTools with QtWebKit support,
>>>>>>      for example this configuration is supported in Gentoo out of the box.
>
> [...]
>>>>>  But not on Windows, am I right?
>>  Why not? Current version of QtWebKit from 5.212 works on Windows,
>>  there are binaries at
>>
>>  http://download.qt.io/snapshots/ci/qtwebkit/5.212/latest/qtwebkit/
>
> Extracted into qtbase and Assistant builds like a charm! However running
> it gives
>
> "The procedure entry point
> ?staticMetaObject at QSslSocket@@2UQMetaObject@@B could not be located in
> the dynamic link library D:\Qt\gerrit\qt5\qtbase\bin\Qt5WeKit.dll".
>
> I have checked out the Qt dev branch from May 11, which I can imagine
> could cause problems. Do you happen to know which Qt version those
> QtWebKit binaries are known to work with?

5.10

-- 
Regards,
Konstantin



More information about the Development mailing list