[Development] Proposal: Deprecate QVector in Qt 6
julius.bullinger at gmail.com
Thu Apr 23 17:04:27 CEST 2020
On 23.04.2020 16:45, Giuseppe D'Angelo via Development wrote:
> == Naming of functions and types if QList = QVector ==
> We have QStringList, QVariantList and friends, which are aliases /
> subclasses of QList<QString> and so on.
> Should they become QStringVector, QVariantVector; and the *List names
> stay, aliases for the *Vector names, mirroring QList and QVector
Another suggestion: Get rid if the aliases; use the fully-qualified
I'm always irritated if I open the documentation of QVariantList from
within Qt Creator, and land on the QVariant docu instead. I'm interested
in the features of the container, not the contained type.
And I have to remember if QStringList is the same as as QList<QString>,
or if it's actually a different container with a different API.
More information about the Development