[Development] Proposal: Deprecate QVector in Qt 6
apoenitz at t-online.de
Thu Apr 23 17:55:43 CEST 2020
On Thu, Apr 23, 2020 at 05:04:27PM +0200, Julius Bullinger wrote:
> On 23.04.2020 16:45, Giuseppe D'Angelo via Development wrote:
> > == Naming of functions and types if QList = QVector ==
> > We have QStringList, QVariantList and friends, which are aliases /
> > subclasses of QList<QString> and so on.
> > Should they become QStringVector, QVariantVector; and the *List names
> > stay, aliases for the *Vector names, mirroring QList and QVector
> > themselves?
> Another suggestion: Get rid if the aliases; use the fully-qualified types
In case of QStringList that would be QStringList.
More information about the Development