[Development] [Releasing] HEADS-UP: Qt 5.15 Feature Freeze is in effect now

Thiago Macieira thiago.macieira at intel.com
Wed Feb 5 19:43:43 CET 2020


On Wednesday, 5 February 2020 09:41:58 PST Alexander Akulich wrote:
> On Wed, Feb 5, 2020 at 6:58 PM Thiago Macieira
> 
> <thiago.macieira at intel.com> wrote:
> > The correct signal for an error situation is errorOccurred, like in
> > QLocalSocket and QProcess.
> 
> Actually both QLocalSocket and QAbstractSocket renamed the "error()"
> getter to keep using "error()" signal as opposed to many other Qt
> modules "errorOccurred()" signals.

Which is the opposite of QProcess and violates the naming convention. Signals 
are named after verbs in the past tense and properties & property getters are 
simple nouns. So "error" is the getter, "errorOccurred" is the signal.

qprocess.h:

#if QT_DEPRECATED_SINCE(5, 6)
    QT_DEPRECATED_X("Use QProcess::errorOccurred(QProcess::ProcessError) 
instead")
    void error(QProcess::ProcessError error);
#endif
    void errorOccurred(QProcess::ProcessError error);


-- 
Thiago Macieira - thiago.macieira (AT) intel.com
  Software Architect - Intel System Software Products





More information about the Development mailing list