[Development] [Releasing] HEADS-UP: Qt 5.15 Feature Freeze is in effect now

Timur Pocheptsov timur.pocheptsov at qt.io
Wed Feb 5 20:27:52 CET 2020


https://codereview.qt-project.org/c/qt/qtbase/+/285791

> But ok otherwise. So +1-1=0.

Interesting.

Best regards,
    Timur.
________________________________
From: Development <development-bounces at qt-project.org> on behalf of Thiago Macieira <thiago.macieira at intel.com>
Sent: Wednesday, February 5, 2020 7:43 PM
To: development at qt-project.org <development at qt-project.org>
Subject: Re: [Development] [Releasing] HEADS-UP: Qt 5.15 Feature Freeze is in effect now

On Wednesday, 5 February 2020 09:41:58 PST Alexander Akulich wrote:
> On Wed, Feb 5, 2020 at 6:58 PM Thiago Macieira
>
> <thiago.macieira at intel.com> wrote:
> > The correct signal for an error situation is errorOccurred, like in
> > QLocalSocket and QProcess.
>
> Actually both QLocalSocket and QAbstractSocket renamed the "error()"
> getter to keep using "error()" signal as opposed to many other Qt
> modules "errorOccurred()" signals.

Which is the opposite of QProcess and violates the naming convention. Signals
are named after verbs in the past tense and properties & property getters are
simple nouns. So "error" is the getter, "errorOccurred" is the signal.

qprocess.h:

#if QT_DEPRECATED_SINCE(5, 6)
    QT_DEPRECATED_X("Use QProcess::errorOccurred(QProcess::ProcessError)
instead")
    void error(QProcess::ProcessError error);
#endif
    void errorOccurred(QProcess::ProcessError error);


--
Thiago Macieira - thiago.macieira (AT) intel.com
  Software Architect - Intel System Software Products



_______________________________________________
Development mailing list
Development at qt-project.org
https://lists.qt-project.org/listinfo/development
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/development/attachments/20200205/dfb2dedb/attachment-0001.html>


More information about the Development mailing list