[Development] A modest proposal: disable lower-case keywords (emit, foreach, forever, signals, slots) by default

Allan Sandfeld Jensen kde at carewolf.com
Mon Mar 2 08:47:57 CET 2020

On Monday, 2 March 2020 08:45:29 CET Jaroslaw Kobus wrote:
> Allan Sandfeld Jensen (27 February 2020 23:03) replied:
> > That is how I see it too. It essentially violates Qt code guidelines. If
> > it
> > was a normal method we would name it "emitEmptied()", so far we have just
> > lived with "emit emptied()" instead.
> The issue is that if you want to emit a signal, "emitEmptied()" sounds OK,
> while when you want to connect to it, you don't want to connect to
> "emitEmptied", but to "emptied".
> Just my 4 cents (this amount wasn't offered in this thread, yet).
It came up. There was another suggestion that got around the problem:

it works because signal is both a noun and a verb :)


More information about the Development mailing list