[Development] A modest proposal: disable lower-case keywords (emit, foreach, forever, signals, slots) by default
mwoehlke.floss at gmail.com
Mon Mar 2 16:42:00 CET 2020
On 28/02/2020 15.33, Lars Knoll wrote:
> This is all nice and fun to bike shed about, but I don’t think those
> proposed solutions match the scope of the original problem (which
> was relatively small). I don’t think a massive source compatibility
> breakage is what we want, just because there is one std header using
> emit as a method name.
I read this as: let's not do anything. With which I agree.
> And most of Qt’s signals are named in a way that makes it rather
> obvious it’s a signal we’re looking at (e.g. fooChanged() or
> clicked()), so there’s no need for an ‘emit’ in front to be clear.
I don't see consensus here. On the contrary, the majority seems to feel
that emit/Q_EMIT is useful.
More information about the Development