[Development] A modest proposal: disable lower-case keywords (emit, foreach, forever, signals, slots) by default
Shawn.Rutledge at qt.io
Mon Mar 2 16:56:27 CET 2020
On 28 Feb 2020, at 21:33, Lars Knoll <lars.knoll at qt.io<mailto:lars.knoll at qt.io>> wrote:
So to shortcut this discussion a bit: I am completely opposed to a massive SIC changes/efforts for our signals (like giving them ugly names like emitClicked(), or signal objects).
If people feel strongly, I am open to trying to find a way to keep some sort of ‘emit’ prefix (whether that’s Q_EMIT or a [[qt::emit]] attribute), but I do agree with Marc that we should in the long term try to get away from having emit/signals/slots defined as macros (at least by default).
+1 but I hope we end up getting started on this “long term” project in some form.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Development