[Interest] Suddenly can't access sql database

Thales Lange thaleslange at gmail.com
Sat Aug 4 01:48:32 CEST 2012

Hi Robert.

The QSqlDatabase didn't find the mysql plugin ("libqsqlmysql.so").

I think you updated your system (desktop) and the path to 
"libqsqlmysql.so" was lost. Maybe, QT was compiled without mysql plugin. 
Please, check if your QT has the mysql plugin enabled.

On my linux (Gentoo), the path to this library is 

On windows, I can find it in "$${PATH TO QT}/plugins/sqldrivers".

Best regards,
Thales Lange.

On 03-08-2012 20:24, Robert Wood wrote:
> I have a Qt program I use for talking to my sql database which has been
> working for about three years through various versions of
> [Mandriva/Mageia] Linux. Today, on my desktop only, it has suddenly
> stopped working. Fortunately it still works on my laptop so I can at
> least access it to get at data.
> I have tried to set a breakpoint to see what's going on and I can
> suddenly no longer set breakpoints either.
> I have done some [Mageia] software updates, but I don't particularly
> remember anything to do with Qt. I did do an auto remove orphans which I
> suppose might have done some damage. I've tried uninstalling and
> reinstalling Qt to no avail.
> I can access the mysql database from the command line on my desktop, so
> I guess it's a Qt problem rather than an OS issue.
> The Application Output in Qt says this:
> Debugging starts
> &"warning: GDB: Failed to set controlling terminal: Invalid argument\n"
> QSqlDatabase: QMYSQL driver not loaded
> QSqlDatabase: available drivers: QSQLITE
> QSqlQuery::exec: database not open
> Debugging has finished
> This line:
> &"warning: GDB: Failed to set controlling terminal: Invalid argument\n"
> When Googled talks about gdb  v7.x not working with Qt and I am running
> version 7.2, but I don't remember gdb being updated recently and the
> changelog in Control Centre suggests it's not been updated for quite
> some time. so, as I have been running Qt on this machine with this
> version of Mageia for a few months I a, thinking this is not the issue
> with the debugger. (I am running in debug, not release mode.)
> Anyone able to help please?
> Many thanks.
> _______________________________________________
> Interest mailing list
> Interest at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/interest

More information about the Interest mailing list