[Interest] Phonon video

Joseph Crowell joseph.w.crowell at gmail.com
Sat Mar 31 07:01:10 CEST 2012

Phonon probably isn't broken. Your codecs most likely are. Its 
surprising that Windows Media player will play them though. Windows 
media Player might be the culprit that broke your codecs.
> On 03/29/2012 10:59 AM, Jason H wrote:
>> I hate to ask this, but have you rebooted?
> Along that vein. There is a great sitcom called "The IT Crowd"
> that came out of Great Britain. You can find it on Netflix.
> The line "Have you tried turning it off and on." is used
> constantly. Must see.
> Bill
>> And I'd love to see your filter graph.
>> ----- Original Message -----
>> From: Bo Thorsen<bo at fioniasoftware.dk>
>> To: Jason H<scorp1us at yahoo.com>
>> Cc: Qt Project MailingList<interest at qt-project.org>
>> Sent: Thursday, March 29, 2012 9:59 AM
>> Subject: Re: [Interest] Phonon video
>> Hi Jason,
>> Thanks for the attempt :)
>> As I say in the description, it worked last week, now it doesn't. So
>> it's not a question of installing working codecs, because I didn't
>> uninstall any of them.
>> Also, when I first tried to play the files we use, WMP wasn't able to
>> play them, so Phonon wasn't either. Then I installed the codecs, and
>> both were able to play them. Now, only WMP can play the files.
>> About the QtMultimedia: The detailed description of the module says "The
>> functionality provided by the Phonon Module is on a higher level and in
>> many cases more suitable for application developers."
>> But maybe I have to use it if Phonon is broken beyond reasonable repair.
>> Bo.
>> Den 29-03-2012 15:48, Jason H skrev:
>>> I thought QtMultimediaKit was the way to go?
>>> I would suspect that something in the DS filter graph changed. Verify you have a valid path for the file type you are trying to play: http://msdn.microsoft.com/en-us/library/ms787460.aspx
>>> Keep in mind you still need to install video codecs because mingw version of Qt does not work with Windows7's new media interfaces. Installing K-Lite Codec pack usigally works for me.
>>> ----- Original Message -----
>>> From: Bo Thorsen<bo at fioniasoftware.dk>
>>> To: Qt Project MailingList<interest at qt-project.org>
>>> Cc:
>>> Sent: Thursday, March 29, 2012 8:34 AM
>>> Subject: [Interest] Phonon video
>>> Hi people,
>>> I've been trying to figure out why phonon suddenly doesn't work anymore.
>>> It plays audio just fine but not video. I'm completely stuck.
>>> I built and ran the qmediaplayer demo and saw the same thing, so it's
>>> not my code. And the same code plays the files just fine on Linux. But
>>> just for reference, here it is anyway:
>>>          mPlayer = new Phonon::MediaObject(this);
>>>          mVideo = new Phonon::VideoWidget;
>>>          Phonon::createPath(mPlayer, mVideo);
>>>          if (!mPlayer->hasVideo()) {
>>>              qDebug()<<    "Phonon video sink is not available";
>>>              ...
>>>          }
>>> hasVideo() returns false, and any attempt at adding a video file to
>>> Phonon gives me a "Pause Called" in the debug output window. This is the
>>> code used to play a file:
>>>          mVideo->show();
>>>          mVideo->resize(200, 200);
>>>          mPlayer->enqueue(Phonon::MediaSource(filename));
>>>          mPlayer->play();
>>> Calling Phonon::BackendCapabilities::availableMimeTypes() gives me a
>>> list of 54 mimetypes with both audio and video types in it. The files
>>> I'm trying to play are supported, and Windows Media Player plays them
>>> just fine.
>>> Now here's the really strange part: Last week it worked. But suddenly,
>>> video playback is gone. I have no clue what happened in between. I might
>>> have updated Windows, but if that breaks Phonon, we have a real problem.
>>> I can see that the DS94 backend is still there in both my 4.8.0 and
>>> 4.7.4 plugins.
>>> This really worries me. The code is for a customer with an embedded
>>> system that's going to be deployed on machines in many countries.
>>> Calling those back to fix a Phonon problem *is not* an option. If Phonon
>>> can't deliver a stable environment (and I currently seriously doubt
>>> this), I will have to ditch it.
>>> I obviously tried to search the net for this, and found plenty of people
>>> with the same result. But none with a solution for it. I hope someone
>>> here can help.
>>> I'm on Windows 7 x64 and Windows XP 32 bit, using a fully updated SDK
>>> 2.4.1 with both visual studio 8 and mingw compilers and Qt versions
>>> 4.8.0 and 4.7.4.
>>> Bo Thorsen,
>>> Fionia Software.
>> Bo Thorsen,
>> Fionia Software.
> _______________________________________________
> Interest mailing list
> Interest at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/interest

More information about the Interest mailing list