[Interest] Problem displaying some google charts with QWebView

bar tomas bartomas at gmail.com
Mon Nov 5 21:03:47 CET 2012

Thank you very much for your reply and for trying this out.
I am completely baffled because I still cannot make it display. I've
connected the loadFinished signal to check and it returns True.
I have also tried to load the url
that contains a table into my QwebView, all the page displays well
except for the table itself that is not rendered.
Many thanks if you have any suggestion

On Mon, Nov 5, 2012 at 4:07 PM, Andre Haupt <andre at bitwigglers.org> wrote:
> On Mon, Nov 05, 2012 at 03:11:19PM +0000, bar tomas wrote:
>> Hi,
>> I'm displaying html pages containing interactive Google charts in a
>> QWebView. All google charts work fine except for Table. A Table does
>> simply not display.
>> For instance do you know why the following HTML page (it is the demo
>> for table charts available on the Google charts website:
>> http://code.google.com/apis/ajax/playground/#table) does not display
>> on a QWebView (while all the other charts do)? I've tried tweaking the
>> QWebSettings to no avail.
> works here, on Qt 4.7.4 (Fedora 15):
> #include <QApplication>
> #include <QWebView>
> #include <QFile>
> int main(int argc, char *argv[])
> {
>     QApplication a(argc, argv);
>     QWebView webView;
>     QFile file("your.html");
>     file.open(QIODevice::ReadOnly);
>     webView.setHtml(file.readAll());
>     webView.show();
>     return a.exec();
> }
> regards,
> Andre

More information about the Interest mailing list