[Interest] Compiling QT5

Stephan Kanthak stylon at gmx.de
Sun Nov 11 16:37:38 CET 2012

Hi all,

I'm new to this list and also new to Qt5.

I recently downloaded the beta1 and compiled it for an OMAP4 platform 
according to the following instructions: http://gpupowered.org/node/8 
(originally for the alpha) and http://www.slideshare.net/prabindh 
(except for some tiny patches, looks straightforward in my view). I 
strictly followed the instructions, compiled 
qtbase/qtjsbackend/qtdeclarative/qt3d/qtmultimedia and all seemed to 
work (TI OGLES2 examples, most QT examples, QML demos, Qt3D demos, 
etc.). More precisely, I configured qtbase with:

export BUILD_PATH=/home/stylon/prj/build
./configure --prefix=$BUILD_PATH/usr -release -make libs -xplatform 
linux-arm-gnueabi-g++ -opengl es2 -confirm-license -opensource -no-xcb 
-no-wayland -force-pkg-config -make examples -make demos -verbose

The rest was just cd <dir> && qmake && make && make install as mentioned 
on the pages above.

I even wrote a small QML script myself to test animations and although I 
noticed some tearing and non-smooth animations, all was working fine in 
principle. Due to the little jerky animations I changed the hardcoded 
refreshRate for eglfs from 60 to 50 and tried to recompile, but 
recompilation already failed. I then tried to start from scratch on the 
instructions from prabindh and now I always get the following error 
message when compiling qtdeclarative:

indy:qtdeclarative 2505> make
cd src/ && ( test -f Makefile || /home/stylon/prj/qt/qtbase/bin/qmake 
-o Makefile ) && make -f Makefile
make[1]: Entering directory 
cd qml/ && ( test -f Makefile || /home/stylon/prj/qt/qtbase/bin/qmake 
-o Makefile ) && make -f Makefile
Project ERROR: Unknown module(s) in QT_PRIVATE: v8
make[1]: *** [sub-qml-make_first-ordered] Error 2
make[1]: Leaving directory 
make: *** [sub-src-make_first] Error 2

BTW, /home/stylon/prj/qt is a link to 

As you can see above, the install directory is 
/home/stylon/prj/build/usr and in 
/home/stylon/prj/build/usr/mkspecs/modules I do see qt_v8.pri, but 
strace'ing the call of qmake in the qtdeclarative/src/qml directory 
above shows that qmake instead looks at 
/home/stylon/prj/qt/qtbase/mkspecs/modules where only the qtbase 
configurations can be found. /home/stylon/prj/qt/build/usr is never 
being accessed at all.

Any idea what I do wrong (now)? Any idea why compilation of qt5 worked 
once? I don't know anything about qmake, but overall it looks strange to 
me that qmake from qtbase/bin should be able to know the configuration 
of v8 from qtjsbackend at all the way I configured it now, but I can't 
see how to configure it differently.

Anybody else seeing the same error? At least I found it twice on the web 
via Google, but without mentioning any solution.

Thanks & best,

More information about the Interest mailing list