[Interest] Problem with qmake in qt5-beta on osx creating a static library

Sid Deb sid at pretendllc.com
Thu Sep 13 02:49:19 CEST 2012

I'm porting a graphics app from qt4.6 to qt5.0.beta1 and I've run into a situation where qmake refuses to name my output library correctly.
I'm working on OSX 10.6.8.

Here are the relevant items from the .pro file:
CONFIG			+= staticlib debug_and_release
TARGET		= libUIComponents-QT

This results in a library called "libUIComponents-QT." and not "libUIComponents-QT.a" as expected, which obviously causes problems when trying to link against it.  I've tried omitting the TARGET_EXT specifier, but I get the same result.  It seems that qmake adds the '.' but not the extension, no matter what options I tried setting.  Renaming the library "fixes" the problem, but is obviously not a viable solution.

This was giving the correct result under qt4 (without the TARGET_EXT specifier).

Is this a bug or has qt5 changed how this works, or is something wrong with my setup here?


More information about the Interest mailing list