[Interest] Qt HTTP access to Exchange

Bo Thorsen bthorsen at ics.com
Wed Nov 27 11:18:06 CET 2013

Hi everyone,

I have a Qt 4.8.5 based application that grabs free busy info from an 
Exchange server. This works perfectly, or rather it did.

Now there is a user who have tried to access with a domain\user pair, 
and that fails in a weird way.

I have single stepped through all of the network code and I just can't 
find any place where this fails. It looks like Exchange just closes the 
socket without giving me an error.

My URL to the server is something like 
"https://mail.somewhere/EWS/Exchange.asmx". I sent this a post request 
with an XML body.

I can see that the receiver requests the body data, but then the line is 
silently dropped. The finished signal is emitted from the request and 
error() says there's no error.

I have tried different things for the username and password. First 
attempt is to do the same as I do for usernames without a domain:


This doesn't work for usernames with domain info.

I have also tried removing those, expecting a authenticationRequired or 
proxyAuthenticationRequired. No such call is coming.

I have also tried url encoding the domain\username but that didn't work 

I don't like admitting it, and it's been years since this last happened. 
But I'm stuck. Any help is much appreciated.

As I said, this all works perfect when there's no domain name for the 
user. So the problem is somewhere in authenticating with the Exchange 


Bo Thorsen, European Engineering Manager, ICS
Integrated Computer Solutions. Delivering World-Class Applications

More information about the Interest mailing list