[Interest] Qt HTTP access to Exchange

Mandeep Sandhu mandeepsandhu.chd at gmail.com
Wed Nov 27 11:33:57 CET 2013

> I have single stepped through all of the network code and I just can't
> find any place where this fails. It looks like Exchange just closes the
> socket without giving me an error.

You can confirm this with a packet sniffer to see which end initiated the close.

> My URL to the server is something like
> "https://mail.somewhere/EWS/Exchange.asmx". I sent this a post request
> with an XML body.

Just to eliminate the obvious, you're not getting any SSL errors right
(or being silently ignored)?

> I can see that the receiver requests the body data, but then the line is

How do you see the receiver request the body data? I think the POST
data is sent along in the request itself. The receiver will be
expecting the POST data to be present after the HTTP headers.

> silently dropped. The finished signal is emitted from the request and
> error() says there's no error.
> I have tried different things for the username and password. First
> attempt is to do the same as I do for usernames without a domain:
>      url.setUserName(connector->userName());
>      url.setPassword(connector->password());
> This doesn't work for usernames with domain info.
> I have also tried removing those, expecting a authenticationRequired or
> proxyAuthenticationRequired. No such call is coming.
> I have also tried url encoding the domain\username but that didn't work
> either.

The domain name might be case-sensitive, so you can verify if the
correct case is being used.


More information about the Interest mailing list