[Interest] Cannot start Android projects from QtCreator

Cornelius Hald hald at icandy.de
Sun Oct 27 12:30:47 CET 2013

Even if I hard-code ANDROID_TARGET_ARCH in android-g++ mkspec it fails
with the same error.

On Sun, 2013-10-27 at 11:30 +0100, Cornelius Hald wrote:
> Hi,
> while using the official Qt-5.2-beta1 packages things work like
> expected.
> I've now created a self-compiled Qt for Android from Git stable and
> added it as a kit to QtCreator-3.0-beta1. If this kit is selected the
> "run" and "start debugging" buttons are grayed out.
> If I switch back to the kit containing the official Qt version, the
> buttons get enabled again.
> Additionally, if I right-click on my project and select "deploy" I get
> the following message:
> ---
> No Android arch set by the .pro file.
> Error while building/deploying project myproject (kit: Android-X86)
> When executing step 'Deploy to Android device'
> ---
> I've tried defining ANDROID_TARGET_ARCH and ANDROID_ARCH in my .pro
> file, but that didn't help. Also it should be defined already by the
> mkspec.
> Does anyone have some further hints?
> Thanks!
> Conny
> _______________________________________________
> Interest mailing list
> Interest at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/interest

More information about the Interest mailing list