[Interest] Compiling 5.3.1 on iOS arm64

Tom Ward tward at thefoundry.co.uk
Mon Aug 18 11:00:38 CEST 2014

Hi Richard,

Thanks for the response! I tried adding "CONFIG -= neon" to the
default_pre.prf as described, but it didn't seem to do anything. So I next
tried changing the CFG_NEON setting in qtbase/configure to "no", but that
didn't stop it either.

I'm fine to disable neon acceleration if needs be, just not sure how to do
it exactly?

Has anyone else tried to brave doing this, or am I opening a can of worms?!

For the record, I tried simply ifdef'ing out the neon assembly and
everything else seemed to compile. I'll try dust off my intrinsic knowledge
and give re-writing the above a go, but would be interested if anyone else
had attempted this, and if there's anything else I should do (new Qt


On Mon, Aug 18, 2014 at 8:11 AM, Gustavsen Richard <
Richard.Gustavsen at digia.com> wrote:

>  In mkspecs/macx-ios-clang/default_pre.prf we set CONFIG -= neon for
> iphone simulator builds. You could try to set it for device build builds as
> well.
>  -Richard
>  ------------------------------
> *Fra:* interest-bounces+richard.gustavsen=digia.com at qt-project.org
> [interest-bounces+richard.gustavsen=digia.com at qt-project.org] på vegne av
> Tom Ward [tward at thefoundry.co.uk]
> *Sendt:* 17. august 2014 02:40
> *Til:* interest at qt-project.org
> *Emne:* [Interest] Compiling 5.3.1 on iOS arm64
>   Hello all,
>  I'm currently trying to re-compile Qt 5.3.1 for iOS to support arm64,
> but am getting a compiler error that I'm unable to fathom.
>  To build, I did the following:
>  - Modified qtbase/mkspecs/macx-ios-clang/qmake.conf to change the
> deployment target to 7.1 (as I believe arm64 is only available on this
> version) and the QMAKE_IOS_DEVICE_ARCHS to arm64.
>  - ran configure with the following arguments:
> *./configure -xplatform macx-ios-clang -release -sdk iphoneos7.1
> -no-framework -no-openssl -prefix /tmp/ios7.1-armv64 *
>  - run make
>  Here's the compiler errors I get:
>  image/qimage_neon.cpp:78:17: error: vector register expected
>                 "vld3.8     { d0, d1, d2 }, [%[SRC]] !\n\t"
>                 ^
> <inline asm>:1:15: note: instantiated into assembly here
>         vld3.8     { d0, d1, d2 }, [x1] !
>                      ^
> image/qimage_neon.cpp:78:57: error: unrecognized instruction mnemonic
>                 "vld3.8     { d0, d1, d2 }, [%[SRC]] !\n\t"
>                                                         ^
> <inline asm>:2:2: note: instantiated into assembly here
>         vswp d0, d2
>         ^
> ...
>  I've done a load of googling, and all I can find is a gist that was
> posted by an apparent qt developer:
> https://gist.github.com/torarnv/6582663
>  Any help would be much appreciated! Am more than happy to help, but my
> neon-fu isn't good enough to figure this one out!
>  Thanks

Tom Ward
The Foundry,
5 Golden Square, London, W1F 9HT
Tel: +44(0) 20 7479 4350   Web: www.thefoundry.co.uk

The Foundry Visionmongers Ltd.
Registered in England and Wales No: 4642027
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20140818/665ea06c/attachment.html>

More information about the Interest mailing list