[Interest] macdeployqt errors on Qt 5.3.1

Michael Jackson imikejackson at gmail.com
Sat Aug 23 20:41:03 CEST 2014

I am trying to use macdeployqt to deploy my application. I am using OS X 10.8.5 with Stock Xcode 5.x and Qt 5.3.1 (Self Built - No webkit). It seems to have worked once but now when I run it on my .app bundle I get the following error:

Log: Deploying plugins from "/Users/mjackson/Workspace/DREAM3D_Rewrite/qt5/plugins"
ERROR: file copy failed from "/Users/mjackson/Workspace/DREAM3D_Rewrite/qt5/plugins/platforms/libqcocoa.dylib"
ERROR:  to "Bin/PluginMaker.app/Contents/PlugIns/platforms/libqcocoa.dylib"

Here is the setup:
/Users/mjackson/Workspace/DREAM3D_Rewrite/ is my project directory
/Users/mjackson/Workspace/DREAM3D_Rewrite/qt5 is my build directory
/Users/mjackson/Workspace/DREAM3D_Rewrite/plugins exists but I build my OWN plugins in that directory

My project uses CMake. I am trying to figure out where this is going wrong. Any help is much appreciated. I have tried with a completely clean shell (NO variables exported in case that was an issue). I blew away the Qt directory, went back to the directory where I built Qt and did "make install; make install_docs" and that did not solve the issue either. 

Thanks for any help

Mike Jackson

More information about the Interest mailing list