[Interest] Testing with Windows Phone, first impressions

Harri Pasanen harri at mpaja.com
Tue Dec 30 11:48:02 CET 2014

I picked a Lumia 530 for Christmas to see how does Qt perform on Windows 
Phone 8.1.
I have not used a Windows Phone before, so some of my struggles can be 
attributed to that.
I'm somewhat newbie with Windows 8.1 as well, more used to Windows 7 or 
even XP.

I installed Windows 8.1 Pro 64 bit to VirtualBox virtual machine, 
installed Visual Studio 2013 pro.
There already was Visual Studio 2012 in the virtual machine, and Windows 
Phone 8.0 SDK seemed to bring in some express version as well.

Host in this case is Kubuntu 14.04 amd64 running on older Dell studio 17 
with core i5, 6 Gb of ram and 250 Gb SSD.   I let the VM have about 3 gb 
of RAM.

Connected the phone with usb, ticked devices/usb devices/Microsoft Lumia 
530 in the VirtualBox so that the phone was visible to the virtual machine.
I started Visual Studio 2013 and registered the device for development 
there, I'm not sure if this a required step but would expect so.

Downloaded Qt online installer, which spent a long time setting 
everything up.
I tried to tick pretty much everything required for Windows Phone 
development,  but in the end I did not see Windows Phone arm kit 
anywhere when Qt creator started.  Perhaps I made some mistake.

Went to control panel and uninstalled Qt to start again.
I downloaded Qt 5.4.0 for Windows RT 32 bit offline installer and 
installed that.
Now success, I got three kits: Windows Phone arm MSVC2013, Windows Phone 
x86 MSVC2013 (emulator) and Windows Runtime 64 bit.   Note that I cannot 
run the emulator, VirtualBox does not expose the hardware virtualisation 
support to guests and the emulator requires it.

I tried building the default qtquick app wizard generated app with 
everything as default, Qt Quick Controls 1.3.  It built and installed, 
showed the Qt logo full screen on the phone for a couple of seconds, and 
then closed.  On Windows Runtime it worked ok, showing the 3 buttons.

I tried another app, now picking Qt Quick 2.4.   This time it ran on the 
phone, but the MouseArea did not respond to any touches.  So it 
displayed "Hello World", but did not exit when tapping it, only exited 
with phone UI back button.

I tried a third variation, but that resulted in this message: Failed to 
install the package: 0x81030119 "Unable to install application. The 
maximum number of developer applications on this phone has been reached. 
Please uninstall a developer application and try again."

So the maximum number of developer apps by default is 2 for windows 
phone, wtf!?   I guess google time to find out if this limit can be 

Another note,  for some reason Qt Linguist, Designer and qt3dservice 
each now appear 3 times on Windows 8.1 Apps by Name list (metro desktop?)

Right now I'm only impressed by Lumia 530 itself, which seems to be 
solid and responsive phone for under 70 euros, but I'll continue testing 



More information about the Interest mailing list