[Interest] Qt3D 5.7 Native Build on Raspbery Pi error when running examples

Catalin Moldovan moldovan.catalin at gmail.com
Wed Jul 27 18:37:15 CEST 2016

I've managed to compile Qt 5.7 on rpi3. Most of the essentials packages
with Qt3D as well (after removing assimp from qt3d/src/plugins/sceneparsers/
sceneparsers.pro). I didn't managed to build with assimp support (tried the
package from jessie and also built from source).

My problem is that many examples (e.g. simple-qml) quit and hang my pi with
: "QOpenGLShader::link: ERROR:CUSTOM-28 (vertex shader, line 1) Incorrect

Having a look at the source code and the shaders from extras it seems that
qt3d is trying to use and compile the gl3 shaders instead of the gles2
shaders. Any suggestions on how to fix this?

This is the configure command I've used:
./configure -release -opengl es2 -tslib -force-pkg-config -opensource
-confirm-license -make libs -device linux-rpi3-g++ -device-option
CROSS_COMPILE=/usr/bin/ -optimized-qmake -reduce-exports
-no-use-gold-linker -prefix /usr/local/qt5pi

I've also tried for days to configure/build without faking cross compile
with no luck

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20160727/93e3cac2/attachment.html>

More information about the Interest mailing list