[Interest] Qt3D 5.7 Native Build on Raspbery Pi error when running examples

Oleg Evseev ev.mipt at gmail.com
Wed Jul 27 19:25:36 CEST 2016

Hi, Catalin

This problem was already filed to Jira:
and this is in fact a dublicate of this:


as you see there is commit that fix it. It's not yet merged into qt3d 5.7
You can cherry pick those commits in this order to the latest qt3d 5.7
commit c3fdb888fbd94de0f6b7b1a6859cba8132ecc93d:

1. https://codereview.qt-project.org/#/c/164993/2
2. https://codereview.qt-project.org/#/c/164994/2
3. https://codereview.qt-project.org/#/c/164995/2
4. https://codereview.qt-project.org/#/c/164996/

And if should fix this problem.
At least in my case for same problem on android
https://bugreports.qt.io/browse/QTBUG-54782 it helps.

Regards, Oleg

2016-07-27 19:37 GMT+03:00 Catalin Moldovan <moldovan.catalin at gmail.com>:

> Hi,
> I've managed to compile Qt 5.7 on rpi3. Most of the essentials packages
> with Qt3D as well (after removing assimp from qt3d/src/plugins/sceneparsers/
> sceneparsers.pro). I didn't managed to build with assimp support (tried
> the package from jessie and also built from source).
> My problem is that many examples (e.g. simple-qml) quit and hang my pi
> with : "QOpenGLShader::link: ERROR:CUSTOM-28 (vertex shader, line 1)
> Incorrect #version"
> Having a look at the source code and the shaders from extras it seems that
> qt3d is trying to use and compile the gl3 shaders instead of the gles2
> shaders. Any suggestions on how to fix this?
> This is the configure command I've used:
> ./configure -release -opengl es2 -tslib -force-pkg-config -opensource
> -confirm-license -make libs -device linux-rpi3-g++ -device-option
> CROSS_COMPILE=/usr/bin/ -optimized-qmake -reduce-exports
> -no-use-gold-linker -prefix /usr/local/qt5pi
> I've also tried for days to configure/build without faking cross compile
> with no luck
> Thanks,
> Catalin
> _______________________________________________
> Interest mailing list
> Interest at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/interest
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20160727/64fee30e/attachment.html>

More information about the Interest mailing list