[Interest] Mac: a bit of 10.9 love
Jake.Petroules at qt.io
Thu Aug 3 20:32:01 CEST 2017
Qt 5.9 requires macOS 10.10, *period*. If you want 10.9 support, then you'll have to use Qt 5.8.
The fact that the operating system allows libraries explicitly marked as requiring macOS 10.10, to even be loaded on 10.9, is mind-boggling to me.
> On Aug 3, 2017, at 11:23 AM, Konstantin Tokarev <annulen at yandex.ru> wrote:
> 03.08.2017, 21:15, "Michael Jackson" <mike.jackson at bluequartz.net>:
>> I am curious to find out just how many customers of your application
>> there are that are _still_ on macOS 10.9?
> I don't think "customers" is the right word in the context of MacPorts :)
>> Even if it is just a few why are you letting just a few customers hold
>> you back from using newer compilers, versions of C++, newer tools. Why
>> are you letting those few customers make you take your valuable time to
>> backport all this stuff? Unless those are customers that are paying you
>> a lot of money to keep the compatibility or there is a hard contractual
>> requirement to keep the compatibility...
>> In our own project we tried to maintain that backward compatibility but
>> we finally realized that we were just holding ourselves back because we
>> didn't have access to all the new C++ features in C++11, 14 and upcoming
>> 17 specs that we wanted to use. Both to code more efficiently and to
>> make our lives easier. We just started punting old compilers and support
>> for those. We did one last release based on the older libraries,
>> informed our users of the migration to newer tools and have not looked back.
>> Michael A. Jackson
>> BlueQuartz Software, LLC
>> [e]: mike.jackson at bluequartz.net
>> René J.V. Bertin wrote:
>>> On Thursday August 03 2017 17:11:56 Allan Sandfeld Jensen wrote:
>>>> Didn't Qt only drop support for building on 10.9? I am pretty sure
>>>> you should be able to build on 10.10+ and deploy to 10.9 if you
>>>> wish. Though I can see
>>> Nope, sadly that's not the case (and I doubt it was the intention
>>> either). You can still install Qt 5.9.1, once you figure out how to
>>> run the installer - last time I tried even the MaintenanceTool.app
>>> insisted on self-updating to a new version that crashed immediately
>>> because of missing symbols referenced from the cocoa QPA. I filed a
>>> QTBUG-61800 about that because it made it impossible to update even
>>> supported Qt versions on OS versions not supported by the latest Qt
>>> The workaround trick I found was to force Qt to use the generic Unix
>>> QPA, which is good enough for basic installers but evidently not for
>>> a meaningful user experience.
>>> On Thursday August 03 2017 15:14:52 Alexandru Croitor wrote:
>>>> Iirc the minimum deployment version was bumped to 10.10 in qt 5.9.
>>>> That was also a change we had to do in webengine
>>> I'm expecting to run into>=10.10 requirements elsewhere in Qt 5.9
>>> when I get around to building it, and I was already afraid that QWE
>>> would require more attention than I really care to give it (it's way
>>> too big to start hacking around in) ... But, "had to" as in "were
>>> obliged to" rather than "chose to"? Why - the BT code that already
>>> required using the 10.10 SDK maybe? All incompatibilities I've seen
>>> in the style and QPA were quite trivial to address (except for those
>>> requiring the "full" 10.10 SDK which 10.9 never got).
>>> With some luck it will still be possible to build QWE 5.8 against Qt
>>> 5.9 though, should there be too much to reintroduce (and I wouldn't
>>> mind either dropping BT support either in my build).
>>> R. _______________________________________________ Interest mailing
>>> list Interest at qt-project.org
>> Interest mailing list
>> Interest at qt-project.org
> Interest mailing list
> Interest at qt-project.org
Jake Petroules - jake.petroules at qt.io
The Qt Company - Silicon Valley
Qbs build tool evangelist - qbs.io
More information about the Interest