[Interest] Can't run Qt application under UWP kit

Alexander Dyagilev alervdvcw at gmail.com
Tue Jan 24 09:41:21 CET 2017

On 1/24/2017 10:53 AM, Maurice Kalinowski wrote:
> Does it work for example applications? Trying that would at show 
> whether it’s the tools or something in your project.

Yes. Gallery example runs fine.

> Did you also rebuild all your DLLs for UWP and are all your DLLs UWP 
> compatible?

Yes, of course. All these my DLLs are Qt-based DLLs and thus should be 
UWP compatible. Am I right?

> The error itself reads a bit like 
> https://bugreports.qt.io/browse/QTBUG-54251 but then again, I fixed 
> that for 5.7.1. However, there might be some information valuable for 
> you as well.
> Maurice
> *From:*Interest 
> [mailto:interest-bounces+maurice.kalinowski=qt.io at qt-project.org] *On 
> Behalf Of *Alexander Dyagilev
> *Sent:* Tuesday, January 24, 2017 8:37 AM
> *To:* interest at qt-project.org
> *Subject:* [Interest] Can't run Qt application under UWP kit
> Hello,
> My app is Qt Quick Controls 2 based app. Qt 5.7.1, Windows 10, Visual 
> Studio 2015.
> Desktop 32bit version works fine.
> But when I switch to *Qt 5.7.1 for Universal Windows Platform 32bit* 
> kit, it fails to run with the following error:
> winrtrunner --device 0--start --stop --install --wait 0--profile appx 
> C:/Work/Source/build-MusicPlayer-Qt_5_7_1_for_Universal_Windows_Platform_32bit-Release/bin/player.exe
> qt.winrtrunner:Usingthe Appxprofile.
> qt.winrtrunner:Failedto activate application:0x8027025b"The app didn't 
> start."
> Errorwhileexecuting the WinRTRunnerTool:Processcrashed
> It states here 
> <https://forum.qt.io/topic/50638/start-application-on-winrt> that some 
> dependency is missing. I've checked it using Dependency Walker and it 
> seems that all the required DLLs are in the application's folder. I've 
> also tried to copy just all the files from Qt kit installation into 
> app's dir.
> My application consists of one main executable and three .DLL files. 
> I've launched windeployqt for the each of them. Tried both debug and 
> release versions.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20170124/1b9a5b84/attachment.html>

More information about the Interest mailing list