[Interest] Using macdeployqt after Qbs

Charles-Elie Gentil mail at jiyuusoft.net
Fri Jun 2 09:04:53 CEST 2017

Hi Jake,

Thank you for your quick reply.

Yes, that’s it.

I tried copying my .app bundle to a different location, and it works better, but I always have a problem.

Here, my source code. After building it and depending the case, I pasted the .app bundle in bin/debug or bin/release.

For debug I use this line :
	/Applications/Qt/5.9/clang_64/bin/macdeployqt test.app -use-debug-libs

and for release, I use this line :
    /Applications/Qt/5.9/clang_64/bin/macdeployqt test.app
Libs are correctly pasted, but I can’t run the program if I click on it (see the errorMessage).

With a built .app bundle with qmake, I don’t have problem.

Thank you for your help

Best regards,


mail at jiyuusoft.net

> Le 1 juin 2017 à 21:30, Jake Petroules <Jake.Petroules at qt.io> a écrit :
> Hi Charlie,
> You said that you don't have a problem initially compiling the project in Qt Creator with Qbs. Do you mean that your initial build succeeds, then you run macdeployqt, and then you run the Qbs build again and receive the failure below?
> Please show your project files so we can better understand what's going wrong. My initial guess is that your app's installation Group might be wrong. Please check the second paragraph in the "Breaking Changes" section of https://blog.qt.io/blog/2017/05/29/qbs-1-8-released/
> Also note two things:
> - You are not supposed to modify the contents of the qbs build output directory (which in your case is /Users/charlie/build-untitled2-Desktop_Qt_5_9_0_clang_64bit-Debug/qtc_Desktop__23fa2072-debug). Instead, you should copy your .app bundle to a different location before running macdeployqt on it.
> - In a future release of Qbs (hopefully 1.9) we will have functionality to bundle frameworks directly in the build system, so you will not need to (and should not) use macdeployqt anymore.
>> On Jun 1, 2017, at 12:20 PM, Charles-Elie Gentil <mail at jiyuusoft.net> wrote:
>> Hello friends,
>> I don’t have problem to compile the start project of Qt Creator with Qbs. Now, I want use macdeployqt with this line in %{buildDir} :
>> 	macdeployqt untitled2.app
>> Unfortunately, in my cas, I have this error :
>> 	:-1: erreur : Installation error: Could not copy file '/Users/charlie/build-untitled2-Desktop_Qt_5_9_0_clang_64bit-Debug/qtc_Desktop__23fa2072-debug/untitled2.qtc-Desktop--23fa2072.b0b37170/.tmp/untitled2' to '/Users/charlie/build-untitled2-Desktop_Qt_5_9_0_clang_64bit Debug/qtc_Desktop__23fa2072-debug/install-root/untitled2'. Impossible d'ouvrir /Users/charlie/build-untitled2-Desktop_Qt_5_9_0_clang_64bit-Debug/qtc_Desktop__23fa2072-debug/untitled2.qtc-Desktop--23fa2072.b0b37170/.tmp/untitled2 en lecture
>> With the same compiled project with qmake, I don’t have this problem !!!
>> Do you have an idea ? Have you tried to use macdeployqt after a compilation with Qbs with Qt 5.9 ?
>> Thank you in advance,
>> Best regards,
>> Charlie
>> mail at jiyuusoft.net
>> http://blog.jiyuusoft.net
>> _______________________________________________
>> Interest mailing list
>> Interest at qt-project.org
>> http://lists.qt-project.org/mailman/listinfo/interest
> -- 
> Jake Petroules - jake.petroules at qt.io
> The Qt Company - Silicon Valley
> Qbs build tool evangelist - qbs.io

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20170602/766da2f7/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.zip
Type: application/zip
Size: 11515 bytes
Desc: not available
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20170602/766da2f7/attachment.zip>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20170602/766da2f7/attachment-0001.html>

More information about the Interest mailing list