[Interest] [#ID:INC-1251018#] Installation issue.

Bill Crocker william.crocker at analog.com
Mon Mar 11 12:14:02 CET 2019


> If you are installing onto RHEL 6 as indicated in the case settings then this is not supported
>which would explain why it is having this problem, Qt was built on RHEL 7.4 for 
Qt 5.12 as indicated here:
>
>    https://doc.qt.io/qt-5/supported-platforms.html
>
> so you will need to upgrade in order to be able to use Qt 5.12 on RHEL I am afraid.

Unfortunately "I" am not a "You". "I" am a large corporation, subject to the OS 
imposed
by my significant software vendors. Even if I did want to move to a new version
of RHEL, that is a significant process, involving many thousands of machines
that would take over a year.

>

I assume the requirement for RHEL7 is due to a small number
of features that I could not care less about, that most desktop
developers could not care less about.

>

If you can build with GCC 4.8 on "Generic Linux" why does
RHEL7 require GCC 5.3.1

>

So, I guess I have to stick with 5.9 (LTS)

Thanks.

Bill


More information about the Interest mailing list