[Interest] Qt 5.9 and OpenSSL 1.1?

René J.V. Bertin rjvbertin at gmail.com
Wed Mar 20 19:02:46 CET 2019


>You should either use Qt >= 5.10 or build against OpenSSL 1.0.2

Wrong answer :P

If Qt 5.9 is still in LTS it should get commit cfbe03a6e035ab3cce5f04962cddd06bd414dcea cherry picked from the dev branch before 1.0 reaches EOL later this year.

Is that commit sufficient? Getting it to apply to the 5.9 branch was a bit of monks' work but perfectly doable;
see https://trac.macports.org/ticket/58218

The MacPorts project is in the process of migrating the default OpenSSL version to 1.1 . I haven't yet upgraded but am preparing; my patched Qt 5.9.7 seems to work fine with OSSL 1.0.2r .

David: IIRC Qt doesn't work with LibreSSL.

R.


More information about the Interest mailing list