[Interest] Qt 5.9 and OpenSSL 1.1?

Allan Sandfeld Jensen kde at carewolf.com
Thu Mar 21 20:49:21 CET 2019


On Donnerstag, 21. März 2019 10:16:35 CET René J. V. Bertin wrote:
> >> Actually, it doesn't: 5.9 support ends in May 2020, OpenSSL 1.0 in Dec
> >> 2019.> 
> > You're off by one year. 5.9.0 was released May 29, 2017.
> > 
> > (probably a bit later because we are able to
> > make the 5.9.9 release).
> 
> That means some of the dates in the wikipedia article are wrong... but not
> the EOL date :)
> And interesting that I apparently missed 2 releases, my version monitor
> mustn't be as reliable as I thought.
> 
> > > but I'm guessing Qt may not want to depend only on an OpenSSL variant
> > > that's EOL.
> > 
> > Except that it's not EOL. OpenSSL 1.0.2 is still officially supported
> > until
> > 2019-12-31.
> 
> "May want" as in the future, not "doesn't want" now.
> 
> > If you search the commit log, you'll see a number of OpenSSL 1.1 bugfixes.
> > 
> > PS: you should backport those fixes too.
> 
> Indeed! Are they all labelled OpenSSL, or should I rather look at the log
> for the network/ssl folder hope I catch everything?
> Are all fixes in 5.10 and thus in the 5.10 branch?
> 
Just find the patch from one of the distros that did already did the 
backporting. There are at least two, but probably more.

'Allan




More information about the Interest mailing list