[Interest] Removing files/folders in /Applications under macOS

Roman Wüger roman.wueger at gmx.at
Wed Nov 27 16:07:07 CET 2019

Hello Thiago,

At first, thanks for the quick reply.

when I run a simple bash script it works when I run it with sudo.
When I run my Qt application with sudo, then the removeRecursively() only returns false but do not remove anything.

However, I thought that it tries to gain access where dialog appears to enter the administrator.


> Am 27.11.2019 um 15:05 schrieb Thiago Macieira <thiago.macieira at intel.com>:
> On Wednesday, 27 November 2019 04:56:02 PST Roman Wüger wrote:
>> I’m not able to remove files/dies in /Applications programmatically.
> Why not? What was the error? Were you running your application as root?
> -- 
> Thiago Macieira - thiago.macieira (AT) intel.com
>  Software Architect - Intel System Software Products
> _______________________________________________
> Interest mailing list
> Interest at qt-project.org
> https://lists.qt-project.org/listinfo/interest

More information about the Interest mailing list