[Interest] Removing files/folders in /Applications under macOS

David M. Cotter dave at kjams.com
Wed Nov 27 19:07:19 CET 2019

i believe you must provide an "entitlement" for that

https://developer.apple.com/library/archive/documentation/Miscellaneous/Reference/EntitlementKeyReference/Chapters/AboutEntitlements.html <https://developer.apple.com/library/archive/documentation/Miscellaneous/Reference/EntitlementKeyReference/Chapters/AboutEntitlements.html>

> On Nov 27, 2019, at 7:07 AM, Roman Wüger <roman.wueger at gmx.at> wrote:
> Hello Thiago,
> At first, thanks for the quick reply.
> when I run a simple bash script it works when I run it with sudo.
> When I run my Qt application with sudo, then the removeRecursively() only returns false but do not remove anything.
> However, I thought that it tries to gain access where dialog appears to enter the administrator.
> Regards
> Roman
>> Am 27.11.2019 um 15:05 schrieb Thiago Macieira <thiago.macieira at intel.com>:
>> On Wednesday, 27 November 2019 04:56:02 PST Roman Wüger wrote:
>>> I’m not able to remove files/dies in /Applications programmatically.
>> Why not? What was the error? Were you running your application as root?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20191127/ae448a4a/attachment.html>

More information about the Interest mailing list