[Interest] Stepping into Qt sources (Qt 5.14, MinGW 64-bit)

Dmitriy Purgin dpurgin at gmail.com
Sat Jan 25 19:53:23 CET 2020

Hi all,

Since 5.14 the MinGW version of Qt does not include debug libraries. With
the previous versions of Qt, if I wanted to step into the Qt sources, I
used to install the sources with the online installer, pointed to the
sources directory in Debugger Options in Qt Creator, and it just worked.

With version 5.14 I can't debug into the Qt sources anymore, although I've
installed both Qt Debug Information Files and Sources using the online
installer. I don't think it actually installed the debug information files
though because the online installer shows "0.00 bytes" next to the marked
"Qt Debug Information Files" when I start it again. After a quick look in
the installation folder, I don't see anything related to debugging. I would
expect d-suffixed libraries, enormously big .libs or .dlls, or something

Is there anything I miss? How can I debug into Qt 5.14 without having to
compile it myself, just as it worked before?

Thanks & cheers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20200125/b35905bd/attachment.html>

More information about the Interest mailing list