[Interest] Trouble compiling qt3d for qt6 on windows 10

Daniel Patel danielpatel.no at gmail.com
Mon Feb 15 11:03:00 CET 2021

I have compiled qt6.1 from source which works and now I am trying to
compile qt3d also from source by downloading from
and following the qmake instructions from:

I first tried to download and compile qt3d-everywhere-src-6.0.1 but got an
error about missing zlib.h. Instead of trying to fix this I quickly instead
tried with qt3d-everywhere-src-6.0.0 and this compiled fine.
However it only compiled debug dlls and not release dlls. I tried to do
nmake all and nmake release but the latter gave the error "NMAKE : fatal
error U1073: don't know how to make

I then decided to try out the debug build. First I noticed that the qt3d
dlls didnt seem to have been copied over to the correct folder when I did
nmake install. So I copied them over manually and then started
basicshapes-cpp.exe, but this showed the runtime error: Unable to find
renderer plugin for opengl.
Any hints for what to do?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20210215/cb36708d/attachment.html>

More information about the Interest mailing list