[Interest] Qt 5.15 LTS vs Qt 6.2 LTS

Ramakanth Kesireddy rama.kesi at gmail.com
Wed Sep 29 16:36:35 CEST 2021


Thanks for your mail.

Incase of a new project to be started from scratch, do you recommend to use
Qt 6.2 instead of Qt 5.15?

On Thu, 23 Sep, 2021, 15:22 Tuukka Turunen, <tuukka.turunen at qt.io> wrote:

>
>
> Hi,
>
>
>
> Without knowing the details, of course a bit difficult to give definite
> guidance. Generally, if you are now using an earlier release of Qt, it is a
> good approach to first migrate to Qt 5.15 and fix all deprecation warnings
> etc before migrating to Qt 6.x. Just from the development / porting
> viewpoint, i.e. whether you ever ship with Qt 5.15 does not matter in this
> regard. Some small application can be ported directly, but for larger
> codebase it can be beneficial to take this intermediate step.
>
>
>
> Yours,
>
>
>
>                 Tuukka
>
>
>
> *From: *Interest <interest-bounces at qt-project.org> on behalf of Ramakanth
> Kesireddy <rama.kesi at gmail.com>
> *Date: *Thursday, 23. September 2021 at 9.38
> *To: *Qt Interest <interest at qt-project.org>
> *Subject: *[Interest] Qt 5.15 LTS vs Qt 6.2 LTS
>
> Hi,
>
>
>
> Our application on embedded linux uses Qt Quick, Qt5 sqlite, Qt5 Remote
> objects, Qt5 Concurrent, Qt5 Webengine, Qt5 Printsupport along with Qt5Core
> and Qt5GUI.
>
>
>
> As we are currently planning to upgrade to Qt 5.15 LTS, does it makes
> sense to move to Qt 6.2 LTS wrto stability and performance?
>
>
>
> Appreciate your suggestions in this regard.
>
>
>
> Best Regards,
>
> Ramakanth
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20210929/d591976f/attachment.html>


More information about the Interest mailing list