[Interest] debugging on Macintosh

Michael Jackson mike.jackson at bluequartz.net
Thu Apr 28 20:46:42 CEST 2022

This happened to a colleague (sort of). He could debug one executable but not any of the other ones. We tried QtCreator 4.x, 6.x and 7.x. What we finally did was move his QtCreator configuration directory to the side and relaunch QtCreator. That seemed to fix it. Seems like a sledge hammer but it did work. 

Mike Jackson

On 4/27/22, 13:36, "Interest on behalf of John Weeks" <interest-bounces at qt-project.org on behalf of john at wavemetrics.com> wrote:

    I recently lost the ability to debug on my Macintosh. To be sure, we are building with an oldish Xcode and a new Qt Creator. This morning, though, I downloaded Qt Creator 7.01. For a brief, shining moment, I was able to break at a breakpoint, single-step and all the rest. Then I tried again. Gone again. The breakpoints while running still have the X on them.

    Mac OS: 10.14.6
    Xcode: 10.3
    Qt Creator: 7.01

    What should I be checking? The fact that I was able to debug briefly today suggests that there is some setting or, or... something that could be changed to restore my ability to debug.

    -John Weeks

    Interest mailing list
    Interest at qt-project.org

More information about the Interest mailing list