[Interest] Android: debugger not working

Cristian Adam cristian.adam at qt.io
Thu Dec 8 09:09:55 CET 2022


Welcome to the world of native Android development!  In this world you need to really pay attention on which NDK you are using. Things can break on minor versions.

Not every combination of host OS, NDK and Qt is guaranteed to work.

sdk_definitions.json\android\qtcreator\share - qt-creator/qt-creator.git - A cross-platform Qt IDE<https://code.qt.io/cgit/qt-creator/qt-creator.git/tree/share/qtcreator/android/sdk_definitions.json> lists the Qt and NDK version.

Your bug report doesn't mention the NDK version, which is the most important part. The NDK contains the toolchain and the debugger.

Have you tried using Android Studio to setup the development environment? Does the debugger work there?


From: Interest <interest-bounces at qt-project.org> on behalf of Alexander Dyagilev <alervdvcw at gmail.com>
Sent: Thursday, December 8, 2022 06:12
To: interest at qt-project.org <interest at qt-project.org>
Subject: Re: [Interest] Android: debugger not working


Any help? Again, it seems I am the only on the Earth with such a problem.

How can this be...

It's not my app - I've also tried empty apps created by Qt Creator - no

armv7a real device + x86 + x86_64 virtual devices.

Unfortunately I do not have armv8a real device so I can't test it. I
suspect that the only supported platform for debugging is armv8a. At
least under Windows + Amd ryzen7.

On 12/7/2022 5:31 PM, Alexander Dyagilev wrote:
> Hello,
> I'm on Windows 10 + AMD Ryzen7 laptop.
> Is this configuration supported for developing Android applications?
> I never saw Android debugger working in this configuration.
Interest mailing list
Interest at qt-project.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20221208/420d27e2/attachment.htm>

More information about the Interest mailing list