[QBS] Qbs can't work with Windows SDK 7.1

Loaden loaden at gmail.com
Thu Mar 8 02:59:46 CET 2012

Hi, All! After build the latest of master branch, I found Qbs still not
work with Windows SDK.

> D:\qpSOFT\Sources\Qbs\tests\manual\pch>qbs platforms probe
> Detecting MSVC toolchains...
>   Windows SDK detected:
>     version 7.1.7600.0.30514
>     installed in D:\qpSOFT\DEVx86
>     This SDK contains C++ compiler(s).
>     This is the default SDK on this machine.
> Setting up platform WinSDK7.1.7600.0.30514
> Platform 'mingw32' detected in 'D:\qpSOFT\MinGW\MinGW32'.
> D:\qpSOFT\Sources\Qbs\tests\manual\pch>qbs
> Found project file D:\qpSOFT\Sources\Qbs\tests\manual\pch\pch.qbp
> loading project took:  30 ms
> build graph took:  6 ms
> for debug:
>   - [hpp, application] pch as debug
> Scanning for file dependencies...
> precompiling stable.h
> D:\qpSOFT\DEVx86/*VC/*bin/cl.exe /nologo /c /Zm200 /Zc:wchar_t- /EHsc /Zi
> /MDd /DUNICODE /DWIN32 /Yc /
> FpD:\qpSOFT\Sources\Qbs\tests\manual\pch\build\debug\.obj\pch\pch.pch
> /FoD:\qpSOFT\Sources\Qbs\tests
> \manual\pch\build\debug\.obj\pch\stable.obj /TP
> D:\qpSOFT\Sources\Qbs\tests\manual\pch\stable.h /FoD
> :\qpSOFT\Sources\Qbs\tests\manual\pch\build\debug\.obj\pch\stable.obj
> D:\qpSOFT\Sources\Qbs\tests\ma
> nual\pch\stable.h
> ERROR: Process could not be started.
> ERROR: The following products could not be built: pch.
> Build failed.
> --
See D:\qpSOFT\DEVx86/*VC/*bin/cl.exe, It's wrong, It should be
In msvc.js, We can see there add a token 'VC/', So someone can help to
solved it?
I try to remove 'VC', then works well.
But this is not the realy solution.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/qbs/attachments/20120308/38a06713/attachment.html>

More information about the Qbs mailing list