[QBS] Increasing verbosity of targetOS-based on conditions in user code

Alberto Mardegan mardy at users.sourceforge.net
Thu Jun 13 09:37:59 CEST 2013

On 06/13/2013 10:02 AM, Joerg Bornemann wrote:
> Is it really worth it, given that we want extend Array to have a 
> contains method anyway, which would make the code less verbose again?

I find
  condition: qbs.targetOS.contains("windows") ||

much more readable than a "filter" property. Do you plan to allow the
contains() method to receive a list of parameters in order to make the
above even shorter, or would it be possible to write something like:

  condition: qbs.targetOS in ["windows", "darwin"]



http://blog.mardy.it <- geek in un lingua international!

More information about the Qbs mailing list