[Qt-creator] [Development] No headers in Mac frameworks?

Stephen Chu stephen at ju-ju.com
Tue Jul 10 17:00:09 CEST 2012

On 7/10/12 9:28 AM, eike.ziller at nokia.com wrote:
> On 10 Jul 2012, at 15:19, ext Stephen Chu wrote:
>> On 7/10/12 5:41 AM, Stephen Kelly wrote:
>>> On Monday, July 09, 2012 18:11:30 Stephen Chu wrote:
>>>> On 7/9/12 6:03 PM, Shawn Rutledge wrote:
>>>>> On 9 July 2012 22:25, Stephen Chu <stephen at ju-ju.com> wrote:
>>>>>> On 7/9/12 3:53 PM, Stephen Chu wrote:
>>>>>>> On 7/9/12 3:18 PM, Stephen Chu wrote:
>>>>>>>> I built Qt 5 from git on Mac with -developer-build option and find
>>>>>>>> there's no link to headers in the resulted frameworks. There are
>>>>>>>> only
>>>>>>>> symlinks to the libs but not headers like in Qt 4.8.
>>>>>>>> Qt Creator editor has trouble finding the headers with this setup.
>>>>>>>> This makes finding definitions of Qt types almost impossible.
>>>>>>>> It still compiles and builds fine. Just the editor failing to find
>>>>>>>> them.>>>
>>>>>>> OK. I removed and re-add Qt5 install to Creator and now it finds the
>>>>>>> headers. Don't know what happened. :)
>>>>>> Scrap that. It still doesn't work. I hit one of the framework which I
>>>>>> manually added a symlink to the include folder.
>>>>>> Sorry for the back and forth. I believe it's an issue in Qt 5 build
>>>>>> script.>
>>>>> I've seen an issue like that a month or so ago, but then it got fixed.
>>>>>    Which module is it?
>>>> Er. All of them.
>>> Ossi is (hopefully :)) working on generating the includes in the build dir
>>> instead of the source dir. That might fix your issue too.
>>> thread.gmane.org/gmane.comp.lib.qt.devel/4855/focus=4926
>> Thanks. I will watch for the fix. But that issue seems to focus on
>> non-qtbase modules. What I have is none of the frameworks has any header
>> installed within them. Not even QtCore.
> This sounds like the same issue as in the thread "Creator doesn't like my local Qt 5 build?" on the qt-creator mailing list, where Ossi claims that it should be fixed in Qt Creator master?
> Br,

Just pulled and built Creator from git. Still doesn't work without the 
symlinks in the frameworks.

More information about the Qt-creator mailing list