[Qt-creator] Creator 2.7.0 build on Mac 10.8.3 won't launch

Israel Brewster israel at eraalaska.net
Tue Apr 23 17:57:17 CEST 2013

Ok, here we go. Apparently it's not finding a mysql client lib (I did compile Qt with -qt-sql-mysql). Output when I run Qt Creator through GDB:

Reading symbols for shared libraries . done
warning: Tried to remove a non-existent library: /Users/israel/Downloads/qt-creator-2.7.0-src/bin/Qt Creator.app/Contents/PlugIns/QtProject/libCore_debug.dylib
warning: Tried to remove a non-existent library: /Users/israel/Downloads/qt-creator-2.7.0-src/bin/Qt Creator.app/Contents/PlugIns/libUtils_debug.1.0.0.dylib
warning: Tried to remove a non-existent library: /usr/local/qt-5.0.1/lib/QtHelp.framework/Versions/5/QtHelp
warning: Tried to remove a non-existent library: /usr/local/qt-5.0.1/lib/QtSql.framework/Versions/5/QtSql
Failed to load core: /Users/israel/Downloads/qt-creator-2.7.0-src/bin/Qt Creator.app/Contents/PlugIns/QtProject/libCore_debug.dylib: Cannot load library /Users/israel/Downloads/qt-creator-2.7.0-src/bin/Qt Creator.app/Contents/PlugIns/QtProject/libCore_debug.dylib: (dlopen(/Users/israel/Downloads/qt-creator-2.7.0-src/bin/Qt Creator.app/Contents/PlugIns/QtProject/libCore_debug.dylib, 5): Library not loaded: libmysqlclient.18.dylib
  Referenced from: /Users/israel/Downloads/qt-creator-2.7.0-src/bin/Qt Creator.app/Contents/PlugIns/QtProject/libCore_debug.dylib
  Reason: image not found)

Program exited with code 01.

So apparently it can't load the core library because it can't find libmysqlclient.18.dylib Which probably makes some sense, given that libmysqlclient.18.dylib is not in the standard search paths. So the quick fix is probably to link it to a standard path. I'll have to think about a more permanent solution, however, if any apps I build against Qt will have this issue, as I need to be able to distribute them.
Israel Brewster
Computer Support Technician II
Era Alaska
5245 Airport Industrial Rd
Fairbanks, AK 99709
(907) 450-7250 x7293

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Israel Brewster.vcf
Type: text/directory
Size: 417 bytes
Desc: not available
URL: <http://lists.qt-project.org/pipermail/qt-creator/attachments/20130423/7097465c/attachment.bin>
-------------- next part --------------

On Apr 22, 2013, at 11:58 PM, Ziller Eike <Eike.Ziller at digia.com> wrote:

> On 23.04.2013, at 00:46, Israel Brewster <israel at eraalaska.net> wrote:
>> After a clean reinstall of my OS for reasons not related, I did a fresh source build of Qt 5.0.2, followed by a build of Qt Creator 2.7.0. Both builds (apparently, at least) ran without error. Upon trying to launch Qt Creator, however, it immediately exits. The only clue I have found so far is a solitary entry in the console log saying "com.apple.launchd.peruser.501[157] ([0x0-0x20b20b].org.qt-project.qtcreator[78344]) <Error>: Exited with code: 1" No crash report is generated, which (to me) would make sense given that it is exiting "cleanly", just with an error code.
>> The only potentially relevant reference I can find to exit(1) is in the file src/tools/qmlprofilertool/qmlprofilerapplication.cpp, line 249, where it tries to start what appears to be something called  "-qmljsdebugger". It looks like it's supposed to log the error to stderr, but if this is in fact where it is exiting I'm not seeing that happening.
> The stuff in src/tools/ are standalone tools separate from Qt Creator, so not related.
> Qt Creator exits with code 1 if it cannot find its "Core" plugin (though it also should print a message). How did you try to build Qt Creator? (qmake build should work, the qbs build in 2.7 is known to be broken on Mac OS).
> Basically "Qt Creator.app/Contents/PlugIns/QtProject/" should contain files like "Core.pluginspec" (and corresponding libraries).
> Br, Eike
>> Any tips on where to look to figure this out would be appreciated. Incidentally, a seemingly identical build on a different machine (that does not have a clean install of the OS, and as such doubtless has numerous third-party/different versions of libraries installed) did work. It's just this clean machine that it is not working on.
>> -----------------------------------------------
>> Israel Brewster
>> Computer Support Technician II
>> Era Alaska
>> 5245 Airport Industrial Rd
>> Fairbanks, AK 99709
>> (907) 450-7250 x7293
>> -----------------------------------------------
>> <Israel Brewster.vcf>
> -- 
> Eike Ziller, Senior Software Engineer - Digia, Qt
> Digia Germany GmbH, Rudower Chaussee 13, D-12489 Berlin
> Geschäftsführer: Mika Pälsi, Juha Varelius, Anja Wasenius
> Sitz der Gesellschaft: Berlin, Registergericht: Amtsgericht Charlottenburg, HRB 144331 B

More information about the Qt-creator mailing list