[Qt-creator] Can I actually build master with Qt5?

Roland Krause rokrau at yahoo.com
Fri Feb 1 07:45:20 CET 2013

I was trying with todays git clone of Qt5 (Qt-5.0.1 release has the same error though) but build of QtCreator fails:

Ran qmake as: 
/home/rkrause/src/cpp/qt5/qtbase/bin/qmake QT_PRIVATE_HEADERS= -o Makefile ../qt-creat


make[3]: Leaving directory `/home/rkrause/src/cpp/qt-creator.git.qt-5.0.release/src/libs/glsl'

cd qmleditorwidgets/ && ( test -f Makefile || /home/rkrause/src/cpp/qt5/qtbase/bin/qmake /home/rkrause/src/cpp/qt-creator.git/src/libs/qmleditorwidgets/qmleditorwidgets.pro QT_PRIVATE_HEADERS= -o Makefile ) && make -f Makefile 
Project ERROR: Unknown module(s) in QT: declarative
make[2]: *** [sub-qmleditorwidgets-make_first-ordered] Error 3
make[2]: Leaving directory `/home/rkrause/src/cpp/qt-creator.git.qt-5.0.release/src/libs'
make[1]: *** [sub-libs-make_first-ordered] Error 2
make[1]: Leaving directory `/home/rkrause/src/cpp/qt-creator.git.qt-5.0.release/src'
make: *** [sub-src-make_first-ordered] Error 2

Do I need to run a script to convert Qt-4 to Qt-5? 



PS: tried make -i which will build a version but that one fails to run with: 
Failed to load core: Could not find 'Core.pluginspec' in /home/rkrause/src/cpp/qt-creator.git.qt-5.0.release/lib/qtcreator/plugins,/home/rkrause/.local/share/data///QtProject/qtcreator/plugins/2.6.81
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/qt-creator/attachments/20130131/46c29e2e/attachment.html>

More information about the Qt-creator mailing list