[Qt-creator] Building QtCreator 3.1.1 from the zip in QtProjects Downloads

Henry Skoglund fromqt at tungware.se
Wed May 21 12:53:13 CEST 2014


 > P.S. While writing this, QtCtreator 3.1.1 built without problems on
 > my MBP with Xcode 5.1.1/clang-64 and Qt 5.3. So perhaps those build
 > errors occurs only in Windows (haven't tried MinGW or Linux GCC yet).

Just an update: tried building QtCreator 3.1.1 on WinXP with Qt 5.3 
MinGW 4.8.2 32bit: success. Also tried on Windows 8.1 with Qt 5.3 
MSVC2013 64bit: success as well. So maybe I'm the tosser here (!) with 
my Windows 7 MSVC2012 32bit Qt 5.3 that fails the build. (Suspects it 
builds splendidly on Linux as well.)

Also to clarify: if I build my plugin with 5.3, when I try to load it 
into the vanilla 3.1.1 QtCreator, it says: 
The plugin 
uses incompatible Qt library. (5.3.0) [release]

So as I wrote before, plugins need to built using Qt 5.2.1 then they 
load fine.

/Rrgds Henry

More information about the Qt-creator mailing list