[Qt-creator] Building QtCreator 3.1.1 from the zip in QtProjects Downloads

Henry Skoglund fromqt at tungware.se
Fri May 23 10:50:30 CEST 2014

Thanks for looking into this, not terribly important.
Unless someone else also gets stops when building QtCreator 3,1.1 using 
MSVC2012 on Win7SP1 maybe we can write this off as my PC being allergic 
to those bits. Note that unzipping QtCreator 3.0.1 source and building 
it on the same MSVC2012 machine works like a charm.

Re. those line endings, note that I can resume the stopped build by 
rightclicking and selecting "Build core plugin" etc. as I wrote before.
So the build will run to a happy end, it's just not an half hour coffee 
break like in those other cases, you need to manually intervene I think 
4 times.

(Also re. line endings, I discovered that with 5.2. Linux builds happily 
from either the .gz or the ,zip, but OSX doesn't like the .zip.)

Anyway, I want to thank you for Qt being released with every time 
noticeable improvements in quality etc. For example, in 5.1 when you 
created a QtCreator plugin in Linux, you almost every time stumbled on 
small letters/capital letters confusion in the build wizard. But that 
was fixed in 5.2. Having used MSVC for too long time (> 20 yrs) you're 
getting used to releases of Visual Studio being done for political or 
monetary reasons (like MSVC2013 released very soon after MSVC2012). Not 
so with Qt, a strange feeling indeed :-)

Rgrds Henry

On 2014-05-23 10:22, Ziller Eike wrote:
> On May 21, 2014, at 12:53 PM, Henry Skoglund <fromqt at tungware.se> wrote:
>> Hi,
>>> P.S. While writing this, QtCtreator 3.1.1 built without problems on
>>> my MBP with Xcode 5.1.1/clang-64 and Qt 5.3. So perhaps those build
>>> errors occurs only in Windows (haven't tried MinGW or Linux GCC yet).
>> Just an update: tried building QtCreator 3.1.1 on WinXP with Qt 5.3
>> MinGW 4.8.2 32bit: success. Also tried on Windows 8.1 with Qt 5.3
>> MSVC2013 64bit: success as well. So maybe I'm the tosser here (!) with
>> my Windows 7 MSVC2012 32bit Qt 5.3 that fails the build. (Suspects it
>> builds splendidly on Linux as well.)
> Funny. Maybe it’s a line ending style problem? Our source files are originally all linux-style line ending, so if you unzip the source package you need to tell it to transform the line endings of text files, either with whatever UI option your zip client has, or on the command line with “unzip -a ….”. Mingw would probably handle any line ending, and maybe msvc2013 was made less picky there as well?
>> Also to clarify: if I build my plugin with 5.3, when I try to load it
>> into the vanilla 3.1.1 QtCreator, it says:
>> C:\Qt\Tools\QtCreator\lib\qtcreator\plugins\Tungware\GeezerEditQt.dll:
>> The plugin
>> 'C:/Qt/Tools/QtCreator/lib/qtcreator/plugins/Tungware/GeezerEditQt.dll'
>> uses incompatible Qt library. (5.3.0) [release]
>> So as I wrote before, plugins need to built using Qt 5.2.1 then they
>> load fine.
> Right, the plugin loader bails out... . So if you want to provide your plugin to users of the binary download of Qt Creator, you need to make sure that you match the Qt version and compiler version of the Qt Creator in the package (that’s why we also added info about the compiler in Qt Creator’s about dialog). We should be clearer about that in the “extending” manual, and possibly mention that in the README as well (since it’s a more prominent place).
> Br, Eike

More information about the Qt-creator mailing list