[Qt-creator] QtCreator crashes when trying to debug STM32 bare metal device

Axel Jäger axeljaeger at googlemail.com
Sun Sep 14 22:30:36 CEST 2014

Hello Tim,

I forgot to say thank you, everything works now. I also was able to use the Makefile to compile my python-enabled gdb.


Thank you very much,




Von: Tim Hutt [mailto:tdhutt at gmail.com] 
Gesendet: Sonntag, 31. August 2014 22:07
An: Axel Jäger
Cc: qt-creator at qt-project.org
Betreff: Re: [Qt-creator] QtCreator crashes when trying to debug STM32 bare metal device


Yes. I started a long thread about this a while ago. This message has everything I learnt:








The important bit is:


> 6. You must enable "Use asynchronous mode to control the inferior" or
> QtCreator will crash when you pause execution or set breakpoints while it's
> running.

Though I guess the rest of the instructions may help you - e.g. I *did* manage to use the makefile in the QtC repo to build gdb (with the minor modifications listed in that message).


It doesn't work flawlessly but I was able to do some basic breakpoint/step debugging.





On 31 August 2014 19:12, Axel Jäger <axeljaeger at googlemail.com <mailto:axeljaeger at googlemail.com> > wrote:


I got once debugging a STM32 board with the bare metal plugin in QtC working on my mac. Unfortunately, I do not now the exact version of QtC then.


I tried to reproduce the behavior now I have problems to start such a debug session with QtC 3.1.2 again.

-          When trying to flash the target, everything seems fine, I see a lot of messages in the st-util that look promising

-          After that, the debug session does not start. Trying to pause execution or setting a breakpoint crashes the QtCreator

Note that after manually resetting the target, the uploaded programm runs fine without the debugger, so flashing the target seems to work properly.


The behaviour was reproduced on a mac and on a windows machine. In both cases, the compiler from the arm-toolchain from launchpad was used from here:



GDB was recompiled on both cases to have python support. I had no success with the makefile in the QtC-repo but thats another story.


Tim Sander gave me tip that synchronous debugging might be broken in the current release and that I should try async debugging. I tried adding „set target-async on“ to my gdb startup in QtCreator but this seems to not change something. 


Is this a known issue? Does anybody observed similar behaviour? Does anybody know a workaround?


Best regards,


Axel Jäger

Qt-creator mailing list
Qt-creator at qt-project.org <mailto:Qt-creator at qt-project.org> 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/qt-creator/attachments/20140914/370b5a2b/attachment.html>

More information about the Qt-creator mailing list