[Qt-creator] Qt4 to Qt5

Duane duane.hebert at group-upc.com
Tue Dec 1 17:22:58 CET 2015

On 01/12/2015 10:56 AM, Duane wrote:
> I'm not sure if this is a QtCreator issue exactly.  But we're moving to
> Qt5.  I have a project that I have building in Qt 5.  When I launch it
> from the IDE, it seems to run but doesn't open.  I get the debug message
> libGL error: pci id for fd 72: 80ee:beef, driver (null)
> I have tried this with a default Qt project and I get the same thing. If
> I switch to a Qt4 kit, it runs as expected.
> If I build the default project and run it from the command line I get this:
> libGL error: pci id for fd 10: 80ee:beef, driver (null)
> libGL error: core dri or dri2 extension not found
> libGL error: failed to load driver: vboxvideo
> I'm using Oracle Virtual Box so it's possible the problem is there but
> it works ok with Qt4.
> I've tried this with Qt5.3 and 5.5.  I'm using QtCreator 3.5.1 on Fedora
> 21.
> Any ideas?

I found someone suggesting to launch QtCreator with 

This works.

More information about the Qt-creator mailing list